
<!DOCTYPE html>
<html lang="en">
<head>
<meta name="msvalidate.01" content="F5C960002F5B430C22FFD2B55C8D0C7C" />

<style>
        @font-face {
        font-family: 'Pacifico';
        font-style: normal;
        font-weight: 400;
        src: local('Pacifico Regular'), local('Pacifico-Regular'), url(https://fonts.gstatic.com/s/pacifico/v12/FwZY7-Qmy14u9lezJ-6H6MmBp0u-.woff2) format('woff2');
        font-display: swap;
        }
        table {
            border:none;
        }
</style>
<style>
        /*!
         *  Font Awesome 4.3.0 by @davegandy - http://fontawesome.io - @fontawesome
          *  License - http://fontawesome.io/license (Font: SIL OFL 1.1, CSS: MIT License)
           */@font-face{font-family:FontAwesome;src:url(https://netdna.bootstrapcdn.com/font-awesome/4.3.0/fonts/fontawesome-webfont.eot?v=4.3.0);src:url(https://netdna.bootstrapcdn.com/font-awesome/4.3.0/fonts/fontawesome-webfont.eot?#iefix&v=4.3.0) format('embedded-opentype'),url(https://netdna.bootstrapcdn.com/font-awesome/4.3.0/fonts/fontawesome-webfont.woff2?v=4.3.0) format('woff2'),url(https://netdna.bootstrapcdn.com/font-awesome/4.3.0/fonts/fontawesome-webfont.woff?v=4.3.0) format('woff'),url(https://netdna.bootstrapcdn.com/font-awesome/4.3.0/fonts/fontawesome-webfont.ttf?v=4.3.0) format('truetype'),url(https://netdna.bootstrapcdn.com/font-awesome/4.3.0/fonts/fontawesome-webfont.svg?v=4.3.0#fontawesomeregular) format('svg');font-weight:400;font-style:normal}.fa{display:inline-block;font:normal normal normal 14px/1 FontAwesome;font-size:inherit;text-rendering:auto;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;transform:translate(0,0)}.fa-lg{font-size:1.33333333em;line-height:.75em;vertical-align:-15%}.fa-2x{font-size:2em}.fa-3x{font-size:3em}.fa-4x{font-size:4em}.fa-5x{font-size:5em}.fa-ul{padding-left:0;margin-left:2.14285714em;list-style-type:none}.fa-ul>li{position:relative}.fa-li{position:absolute;left:-2.14285714em;width:2.14285714em;top:.14285714em;text-align:center}.fa-li.fa-lg{left:-1.85714286em}.fa-border{padding:.2em .25em .15em;border:solid .08em #eee;border-radius:.1em}@-webkit-keyframes fa-spin{0%{-webkit-transform:rotate(0);transform:rotate(0)}100%{-webkit-transform:rotate(359deg);transform:rotate(359deg)}}@keyframes fa-spin{0%{-webkit-transform:rotate(0);transform:rotate(0)}100%{-webkit-transform:rotate(359deg);transform:rotate(359deg)}}.fa-search:before{content:"\f002"}.fa-user:before{content:"\f007"}.fa-th:before{content:"\f00a"}.fa-th-list:before{content:"\f00b"}.fa-check:before{content:"\f00c"}.fa-close:before,.fa-times:before{content:"\f00d"}.fa-search-plus:before{content:"\f00e"}.fa-search-minus:before{content:"\f010"}.fa-home:before{content:"\f015"}.fa-repeat:before{content:"\f01e"}.fa-tag:before{content:"\f02b"}.fa-print:before{content:"\f02f"}.fa-font:before{content:"\f031"}.fa-italic:before{content:"\f033"}.fa-text-height:before{content:"\f034"}.fa-text-width:before{content:"\f035"}.fa-align-left:before{content:"\f036"}.fa-align-center:before{content:"\f037"}.fa-align-right:before{content:"\f038"}.fa-align-justify:before{content:"\f039"}.fa-list:before{content:"\f03a"}.fa-stop:before{content:"\f04d"}.fa-share:before{content:"\f064"}.fa-expand:before{content:"\f065"}.fa-plus:before{content:"\f067"}.fa-minus:before{content:"\f068"}.fa-random:before{content:"\f074"}.fa-sign-out:before{content:"\f08b"}.fa-sign-in:before{content:"\f090"}.fa-upload:before{content:"\f093"}.fa-group:before,.fa-users:before{content:"\f0c0"}.fa-link:before{content:"\f0c1"}.fa-list-ul:before{content:"\f0ca"}.fa-list-ol:before{content:"\f0cb"}.fa-table:before{content:"\f0ce"}.fa-google-plus:before{content:"\f0d5"}.fa-caret-down:before{content:"\f0d7"}.fa-caret-up:before{content:"\f0d8"}.fa-caret-left:before{content:"\f0d9"}.fa-caret-right:before{content:"\f0da"}.fa-user-md:before{content:"\f0f0"}.fa-code:before{content:"\f121"}.fa-maxcdn:before{content:"\f136"}.fa-html5:before{content:"\f13b"}.fa-css3:before{content:"\f13c"}.fa-anchor:before{content:"\f13d"}.fa-level-up:before{content:"\f148"}.fa-level-down:before{content:"\f149"}.fa-toggle-down:before{content:"\f150"}.fa-toggle-up:before{content:"\f151"}.fa-toggle-right:before{content:"\f152"}.fa-youtube:before{content:"\f167"}.fa-archive:before{content:"\f187"}.fa-toggle-left:before{content:"\f191"}.fa-try:before{content:"\f195"}.fa-google:before{content:"\f1a0"}.fa-child:before{content:"\f1ae"}.fa-tree:before{content:"\f1bb"}.fa-header:before{content:"\f1dc"}.fa-at:before{content:"\f1fa"}.fa-toggle-on:before{content:"\f205"}.fa-user-plus:before{content:"\f234"}.fa-user-times:before{content:"\f235"}.fa-train:before{content:"\f238"}
           </style>
<script>
        (function(d) {
          var wf = d.createElement('script'), s = d.scripts[0];
          wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
          wf.async = true;
          s.parentNode.insertBefore(wf, s);
        })(document);
        </script>
<meta charset="utf-8" />
<title>  Python Iterators And Generators </title>
<meta name="description" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="google-site-verification" content="p8VMYES_r7C9D_1EAhDkSCVP9hKUDSzDj-r6DGdSiV0" />


<style>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</style>

<style>
@font-face{font-family:simple-line-icons;src:url(https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/fonts/Simple-Line-Icons.eot?v=2.4.0);src:url(https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/fonts/Simple-Line-Icons.eot?v=2.4.0#iefix) format('embedded-opentype'),url(https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/fonts/Simple-Line-Icons.woff2?v=2.4.0) format('woff2'),url(https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/fonts/Simple-Line-Icons.ttf?v=2.4.0) format('truetype'),url(https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/fonts/Simple-Line-Icons.woff?v=2.4.0) format('woff'),url(https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/fonts/Simple-Line-Icons.svg?v=2.4.0#simple-line-icons) format('svg');font-weight:400;font-style:normal}.icon-anchor,.icon-check,.icon-close,.icon-control-end,.icon-control-start,.icon-graph,.icon-home,.icon-like,.icon-link,.icon-list,.icon-login,.icon-magnifier,.icon-magnifier-add,.icon-menu,.icon-minus,.icon-notebook,.icon-plus,.icon-share,.icon-tag,.icon-target,.icon-user{font-family:simple-line-icons;speak:none;font-style:normal;font-weight:400;font-variant:normal;text-transform:none;line-height:1;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale}.icon-user:before{content:"\e005"}.icon-login:before{content:"\e066"}.icon-menu:before{content:"\e601"}.icon-list:before{content:"\e067"}.icon-check:before{content:"\e080"}.icon-plus:before{content:"\e095"}.icon-minus:before{content:"\e615"}.icon-close:before{content:"\e082"}.icon-notebook:before{content:"\e013"}.icon-anchor:before{content:"\e029"}.icon-tag:before{content:"\e055"}.icon-share:before{content:"\e05b"}.icon-home:before{content:"\e069"}.icon-graph:before{content:"\e06b"}.icon-like:before{content:"\e068"}.icon-control-start:before{content:"\e06f"}.icon-control-end:before{content:"\e074"}.icon-link:before{content:"\e08d"}.icon-magnifier:before{content:"\e090"}.icon-magnifier-add:before{content:"\e091"}.icon-target:before{content:"\e09e"}
		</style>
<style>
div.row.container > pre {
    background: rgba(0,0,0,0.1);
    color: var(--color-body-color);
    padding: 1.3333em;
    margin: 1.333em 0;
    border-left: 12px solid green;
    font-size: 1em;
    font-weight: 300;
    line-height: 25px;
    white-space: pre;
    word-wrap: normal;
    overflow-x: auto;
    font-family: var(--content-font-family);
    display: block;
    overflow: auto;
}
p {
 word-break: break-word
}
.list-inline {
 word-break: break-word
}

.modal-full-dialog {
    min-width: 100%;
    margin: 10;
}

.list-group-item {
    border:none;
}

.modal-full-content {
    min-height: 100vh;
}
.modal-body {
    max-width: 100%;
    overflow-x: auto;
}

.list-group{
    float: left;
    width: 100%;
}
a.anchor-link:link {
    text-decoration: none;
    padding: 0 20px;
    visibility: hidden
}
.dataframe {
    display: block;
    width: 100%;
    overflow-x: auto;
    -webkit-overflow-scrolling: touch;
	font-size: 87.5%;
}
.input {
  background-color: #edf2f7;
}

pre{
	word-break: break-word;
    white-space: pre-wrap;
}

h1:hover .anchor-link,
h2:hover .anchor-link,
h3:hover .anchor-link,
h4:hover .anchor-link,
h5:hover .anchor-link,
h6:hover .anchor-link {
    visibility: visible
}
body {
      overflow-x: hidden;

}
body {
    font-family: "Segoe UI", Tahoma, sans-serif;
    background-color: #ffffff
}
body { font-size: 1.00rem;  }
footer { font-size: 0.75rem;  }

/*
@media (min-width: 576px) {
        body { font-size: 0.75rem;  }

}*/
@media (min-width: 768px) {
        body { font-size: 1.00rem;  }

}
@media (min-width: 992px) {
        body { font-size: 1.25rem;  }

}
@media (min-width: 1200px) {
        body { font-size: 1.25rem;  }

}
.img-fluid {
      max-width: 100%;
      height: auto;

}

a {
word-break: break-word;
}
.img-responsive {
      display: block;
      max-width: 100%;
      height: auto;
      margin-left: auto;
      margin-right: auto;

}
        </style>

<style>
@font-face{font-family:Icons;src:url(https://www.nbshare.io/static/open-iconic/font/fonts/open-iconic.eot);src:url(https://www.nbshare.io/static/open-iconic/font/fonts/open-iconic.eot?#iconic-sm) format('embedded-opentype'),url(https://www.nbshare.io/static/open-iconic/font/fonts/open-iconic.woff) format('woff'),url(https://www.nbshare.io/static/open-iconic/font/fonts/open-iconic.ttf) format('truetype'),url(https://www.nbshare.io/static/open-iconic/font/fonts/open-iconic.otf) format('opentype'),url(https://www.nbshare.io/static/open-iconic/font/fonts/open-iconic.svg#iconic-sm) format('svg');font-weight:400;font-style:normal}
</style>
<style>

h1, h2, h3, h4, h5, h6, h7 {
  font-family: 'Roboto';
  color: #34495e;
  padding-top: 20px;
}

.sidebar-section {
  position: absolute;
  height: 100%;
  width: 100%;
}


.sidebar-item {
    position: absolute;
    left: 0;
    width: 100%;
    height: 100%;
    
    /* Position the items */
    // &:nth-child(2) { top: 25%; }
    // &:nth-child(3) { top: 50%; }
    // &:nth-child(4) { top: 75%; }
}


.make-me-sticky {
  position: -webkit-sticky;
    position: sticky;
    top: 0;
  padding: 0 15px;
}

.sidebar-item ul {
  list-style: decimal;
  padding-left: 0;
  line-height: 1.4;
  font-size: 1.00rem;
}

.sidebar-item ul li { margin: 10px 0; }

.sidebar-item ul li a {
  color: #8e44ad;
}

.sidebar-item ul a { text-decoration: none; }

.sidebar-item ul ul { padding-left: 15px; }

.sidebar-item ul ul li a {
  color: #3498db;
  font-weight: normal;
}
</style>
</head>
<body class="template-homepage">
<div id="content">
<div class="block-row">
<div class="container" id="container1">
<div class="row">
<div class="col-md-12">
<nav class="navbar navbar-light bg-light navbar-expand-md" role="navigation">
<div class="container">
<button type="button" class="navbar-toggler" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1"> <span class="sr-only">Toggle navigation</span> ☰
</button> <a class="navbar-brand" href="/">NoteBook Share</a>

<div class="modal fade" id="register-modal" tabindex="-1" role="dialog">
<div class="modal-dialog" role="document">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria- hidden="true">Close</span></button>
<h4 class="modal-title text-center" id="registerModelLabel">Register</h4>
</div>
<div class="modal-body">
<div class="row">
<div class="col-md-8 col-md-offset-2">
<p id="loginerror"></p>
<form id="signupForm"><input type="hidden" name="csrfmiddlewaretoken" value="NUXn4hrhN2jimi1U9z6ISWPCvce6CMbgP3keC1A39D4Nrrl8Rm0oeTLD6tkGXW6D">
<div class="form-group">
<input type="text" class="form-control" id="username" name="username" placeholder="username: One word no special characters" required="required" />
<p class="text-danger text-center" id="user-email-exists-error" style="display:none;">User Already registered.</p>
</div>
<div class="form-group">
<input type="text" class="form-control" id="email" name="email" placeholder="Email" required="required" />
</div>
<div class="form-group">
<input type="password" class="form-control" id="password" name="password" placeholder="Password" required="required" />
</div>
<div class="form-group">
<input type="password" class="form-control" id="confirm_password" name="confirm_password" placeholder="Confirm Password" required="required" />
</div>
<div class="form-group text-center">
<input type="submit" value="Sign Up" class="btn  btn-lg btn-block btn-cakemporos" id="signUp-submit">
</div>
</form>
</div>
</div>
<hr />
<div class="row">
<div class="col-md-8 col-md-offset-2 text-center">
<a href="#login-modal" data-toggle="modal" data-dismiss="modal"><b>Login</b></a>
</div>
</div>
</div>
</div>
</div>
</div>


<div class="modal fade" id="login-modal" tabindex="-1" role="dialog">
<div class="modal-dialog" role="document">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria- hidden="true">Close</span></button>
<h4 class="modal-title text-center" id="loginModelLabel">Login</h4>
</div>
<div class="modal-body">
<div class="row">
<div class="col-md-8 col-md-offset-2">
<p id="loginerror"></p>
<form class="login-form" id="loginform"><input type="hidden" name="csrfmiddlewaretoken" value="NUXn4hrhN2jimi1U9z6ISWPCvce6CMbgP3keC1A39D4Nrrl8Rm0oeTLD6tkGXW6D">
<div class="form-group">
<input type="name" name="username" id="login-username" class="form-control" placeholder="username" required="required" maxlength="20" size="20" />
<label id="no-pno-label" class="control-label" for="login-username" style="display:none;">Please enter email address.</label>
</div>
<p class="text-danger text-center" id="no-user-error" style="display:none;">We
didn't find you! Please Register</p>
<div class="form-group">
<input type="password" name="password" id="login-password" class="form-control" placeholder="Password" required="required" />
</div>
<p class="text-danger text-center" id="password-error" style="display:none;">Wrong
Password!</p>
<div class="form-group text-center">
<input type="submit" value="Login" class="btn  btn-lg btn-block btn-cakemporos" id="signUp-Submit">
</div>
</form>
</div>
</div>
<hr />

<div class="row">
<div class="col-md-8 col-md-offset-2 text-center">
<a href="#register-modal" data-toggle="modal" data-dismiss="modal"><b>Register</b></a>
</div>
</div>
</div>
</div>
</div>
</div>

<button class="login-btn btn btn-primary nav-link" data-toggle="modal" data-target="#login-modal" type="button" name="button">Upload/ Login</button>
<button class="signup-btn btn btn-primary nav-link" data-toggle="modal" data-target="#register-modal" type="button" name="button">Sign up</button>
<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
<ul class="nav navbar-nav mt-2 mt-md-0">

</ul>
<div class="btn-group nav-link">
<button type="button" class="btn btn-secondary dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
Notebooks
</button>
<div class="dropdown-menu dropdown-menu-right">
<button class="dropdown-item" type="button"><a class="nav-link" href="/notebooks/R/">R</a></button>
<button class="dropdown-item" type="button"><a class="nav-link" href="/notebooks/python/">Python</a></button>
<button class="dropdown-item" type="button"><a class="nav-link" href="/notebooks/pandas/">Pandas</a></button>
<button class="dropdown-item" type="button"><a class="nav-link" href="/notebooks/data-science/">Data Science</a></button>
<button class="dropdown-item" type="button"><a class="nav-link" href="/notebooks/excel/">Excel</a></button>
<button class="dropdown-item" type="button"><a class="nav-link" href="/notebooks/nlp/">NLP</a></button>
</div>
</div>
<ul class="nav navbar-nav ml-auto">
<li class="nav-item"><a class="navbar-brand" href="/new-post/">Submit Notebook</a></li>

</ul>

</div>

</div>

</nav>
</div>
</div>
<div class="row w-100">
<div class="col-md-12">
</div>
</div>
<div class="row w-100">
<div class="col-md-12">
</div>
</div>
<div class="row">
<div class="col-md-9 col-sm-12 col-xs-12">
<div class="row" style="display:block">
<div tabindex="-1" id="notebook" class="border-box-sizing">
<div class="container" id="notebook-container">
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h1 id="Iterators-and-Generators">Iterators and Generators<a class="anchor-link" href="#Iterators-and-Generators"></a></h1>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>In this notebook, we would explore the difference between iterators and generators, how to use them and also the best use cases for each of them.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h2 id="Iterators">Iterators<a class="anchor-link" href="#Iterators"></a></h2>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>As the name states, a Python iterator is an object that you can iterate upon, which returns one object at a time, therefore enables us to traverse through all values as well.
Iterators are implicitly implemented in for loops and python generators.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>The functions <strong>iter()</strong> and <strong>next()</strong> which we will learn more later in this tutorial are from the iterators.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>The objects which we can iterate upon are called <strong>iterables</strong>. The following are examples of iterables:</p>
<ul>
<li>Lists.</li>
<li>Strings.</li>
<li>Tuples.</li>
</ul>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h3 id="Iterator-Objects-and-Protocols">Iterator Objects and Protocols<a class="anchor-link" href="#Iterator-Objects-and-Protocols"></a></h3>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="c1"># myList is a python list which we learned before is also an iterable.</span>
<span class="n">myList</span> <span class="o">=</span> <span class="p">[</span><span class="mi">1</span><span class="p">,</span><span class="mi">3</span><span class="p">,</span><span class="mi">5</span><span class="p">,</span><span class="mi">7</span><span class="p">]</span>
</pre></div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>We then apply <strong>iter()</strong> function to create a Python iterator object.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="n">iterator_obj</span> <span class="o">=</span> <span class="nb">iter</span><span class="p">(</span><span class="n">myList</span><span class="p">)</span>
<span class="n">iterator_obj</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>&lt;list_iterator at 0x7fdc36ab2bb0&gt;</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>As we can see, now we have a list iterator object. What about accessing the values of our iterable? This is where we second function of the iterator protocol i.e <strong>next()</strong> comes in.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Using the <strong>next()</strong> function it will return the next value inside the iterator object in line. So at first it will return 1, then when call it again, it'll return 3, then 5, then 7. But let's explore what will happen when the last iterator object value has been reached.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">iterator_obj</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>1</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">iterator_obj</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>3</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">iterator_obj</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>5</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">iterator_obj</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>7</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">iterator_obj</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt"></div>
<div class="output_subarea output_text output_error">
<pre><span class="ansi-red-fg">---------------------------------------------------------------------------</span>
<span class="ansi-red-fg">StopIteration</span>                             Traceback (most recent call last)
<span class="ansi-green-fg">&lt;ipython-input-9-31379ae42bad&gt;</span> in <span class="ansi-cyan-fg">&lt;module&gt;</span>
<span class="ansi-green-fg">----&gt; 1</span><span class="ansi-red-fg"> </span>next<span class="ansi-blue-fg">(</span>iterator_obj<span class="ansi-blue-fg">)</span>

<span class="ansi-red-fg">StopIteration</span>: </pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>As you can see, upon reaching the last element of the iterator object, calling <strong>next()</strong> function again will raise a <em>StopIteration</em> exception. This gives rise to the notion that looping over iterables to access values is a better and rather more effecient way.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h3 id="FOR-loop-implementation"><strong>FOR loop implementation</strong><a class="anchor-link" href="#FOR-loop-implementation"></a></h3>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Internally, the for loop creates an iterator object and accesses it's values one by one until the <strong>StopIteration</strong> exception is raised. This is how a for loop is internally implemented.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<pre><code>iter_obj = iter(iterable)
while True:
    try:
        element(next(iter_obj))
    except StopIteration:
        break</code></pre>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>As you can see, the for loop is actually internally using the iterator protocol with an exception handling to iterate over iterables and accessing their values.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h2 id="Creating-our-first-Python-Iterator">Creating our first Python Iterator<a class="anchor-link" href="#Creating-our-first-Python-Iterator"></a></h2>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Now that we know what is the iterator protocol functions and how it works, we can now finally create our own python iterators. So let's create our own very first python iterator which will be responsible for squaring integers.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="k">class</span> <span class="nc">MyIterator</span><span class="p">:</span>
    <span class="c1"># Instantiation method stores the class input in max attribute</span>
    <span class="c1"># to act as check later on</span>
    <span class="k">def</span> <span class="nf">__init__</span><span class="p">(</span><span class="bp">self</span><span class="p">,</span> <span class="nb">max</span> <span class="o">=</span> <span class="mi">0</span><span class="p">):</span>
        <span class="bp">self</span><span class="o">.</span><span class="n">max</span> <span class="o">=</span> <span class="nb">max</span>
    
    <span class="c1"># Sets n to zero</span>
    <span class="k">def</span> <span class="nf">__iter__</span><span class="p">(</span><span class="bp">self</span><span class="p">):</span>
        <span class="bp">self</span><span class="o">.</span><span class="n">n</span> <span class="o">=</span> <span class="mi">0</span>
        <span class="k">return</span> <span class="bp">self</span>
    
    <span class="c1"># Checks if the value of n has reached max or not, if it didn&#39;t</span>
    <span class="c1"># it will square the number stored at n and increment n by one.</span>
    <span class="k">def</span> <span class="nf">__next__</span><span class="p">(</span><span class="bp">self</span><span class="p">):</span>
        <span class="k">if</span> <span class="bp">self</span><span class="o">.</span><span class="n">n</span> <span class="o">&lt;=</span> <span class="bp">self</span><span class="o">.</span><span class="n">max</span><span class="p">:</span>
            <span class="n">res</span> <span class="o">=</span> <span class="bp">self</span><span class="o">.</span><span class="n">n</span> <span class="o">**</span> <span class="mi">2</span>
            <span class="bp">self</span><span class="o">.</span><span class="n">n</span> <span class="o">+=</span> <span class="mi">1</span>
            <span class="k">return</span> <span class="n">res</span>
        <span class="k">else</span><span class="p">:</span>
            <span class="k">raise</span> <span class="ne">StopIteration</span>
</pre></div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>So our iterator has two main attributes, <strong>max</strong> and <strong>n</strong>.</p>
<ul>
<li><strong>max</strong> - an attribute to store user input and acts as check for max value reached</li>
<li><strong>n</strong> - an attribute to check against <strong>max</strong> and incremented each time it doesn't.</li>
</ul>
<p>Now that we wrote our first iterator, let's try it out.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="n">a</span> <span class="o">=</span> <span class="n">MyIterator</span><span class="p">(</span><span class="mi">4</span><span class="p">)</span>
<span class="n">a</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>&lt;__main__.MyIterator at 0x7fdc36ab2ee0&gt;</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="c1"># We now use the __iter__ method we defined previously to initiate</span>
<span class="c1"># the attribute n with zero.</span>
<span class="n">a</span><span class="o">.</span><span class="fm">__iter__</span><span class="p">()</span>
<span class="n">a</span><span class="o">.</span><span class="n">n</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>0</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="n">a</span><span class="o">.</span><span class="fm">__next__</span><span class="p">()</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>0</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="n">a</span><span class="o">.</span><span class="n">n</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>1</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>As we can see in the previous two code blocks, the first value squared was zero and then the value of n was incremented by 1. If we keep on using the methods <strong><strong>next</strong>()</strong> and <strong><strong>iter</strong>()</strong> that we defined, we'll find out that our iterator works as needed.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">print</span><span class="p">(</span><span class="s2">&quot;2nd Iteration&quot;</span><span class="p">)</span>
<span class="nb">print</span><span class="p">(</span><span class="s2">&quot;n: </span><span class="si">%d</span><span class="s2">, squared: </span><span class="si">%d</span><span class="s2">&quot;</span> <span class="o">%</span> <span class="p">(</span><span class="n">a</span><span class="o">.</span><span class="n">n</span><span class="p">,</span> <span class="n">a</span><span class="o">.</span><span class="fm">__next__</span><span class="p">()))</span>
<span class="nb">print</span><span class="p">(</span><span class="s2">&quot;New value for n: &quot;</span><span class="p">,</span> <span class="n">a</span><span class="o">.</span><span class="n">n</span><span class="p">)</span>
<span class="nb">print</span><span class="p">(</span><span class="s2">&quot;3rd Iteration&quot;</span><span class="p">)</span>
<span class="nb">print</span><span class="p">(</span><span class="s2">&quot;n: </span><span class="si">%d</span><span class="s2">, squared: </span><span class="si">%d</span><span class="s2">&quot;</span> <span class="o">%</span> <span class="p">(</span><span class="n">a</span><span class="o">.</span><span class="n">n</span><span class="p">,</span> <span class="n">a</span><span class="o">.</span><span class="fm">__next__</span><span class="p">()))</span>
<span class="nb">print</span><span class="p">(</span><span class="s2">&quot;New value for n: &quot;</span><span class="p">,</span> <span class="n">a</span><span class="o">.</span><span class="n">n</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt"></div>
<div class="output_subarea output_stream output_stdout output_text">
<pre>2nd Iteration
n: 1, squared: 1
New value for n:  2
3rd Iteration
n: 2, squared: 4
New value for n:  3
</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h2 id="Benefits-of-Iterators">Benefits of Iterators<a class="anchor-link" href="#Benefits-of-Iterators"></a></h2>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<ul>
<li>Saving Resources: Iterators are best known for saving resources. Only one element is stored in the memory at a time.If it wasn't for iterators and should we have used lists, all the values would've been stored at once, which means more memory and less efficient.</li>
</ul>
<p>This can come in handy at almost all types of applications, ranging from web applications to AI and neural network models. Whenever we are thinking about minimizing memory usage, we can always resort to iterators.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h3 id="Exercise">Exercise<a class="anchor-link" href="#Exercise"></a></h3>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Now that we know what are iterables, iterators and iterator protocol, let's dive into writing another custom iterator that reverses the iteration over an iterable.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="k">class</span> <span class="nc">ReverseIterator</span><span class="p">:</span>
    
    <span class="c1"># Instantiation method taking in a list and storing it in attribute called data to iterate upon</span>
    <span class="c1"># Attribute called index to mark the length of the collection. The length of the collection matches</span>
    <span class="c1"># the last index of the collection which is where we&#39;ll start our iterations from and go backwards.    </span>
    
    <span class="k">def</span> <span class="nf">__init__</span><span class="p">(</span><span class="bp">self</span><span class="p">,</span> <span class="n">collectnot</span> <span class="n">be</span> <span class="n">exposed</span> <span class="n">toion</span><span class="p">):</span>
        <span class="bp">self</span><span class="o">.</span><span class="n">data</span> <span class="o">=</span> <span class="n">collection</span>
        <span class="bp">self</span><span class="o">.</span><span class="n">index</span> <span class="o">=</span> <span class="nb">len</span><span class="p">(</span><span class="bp">self</span><span class="o">.</span><span class="n">data</span><span class="p">)</span>
    
    <span class="k">def</span> <span class="nf">__iter__</span><span class="p">(</span><span class="bp">self</span><span class="p">):</span>
        <span class="k">return</span> <span class="bp">self</span>
    
    <span class="c1"># The __next__ method checks if the index has reached the 0 (i.e the first element of the collection)</span>
    <span class="c1"># If so, it raises a StopIteration exception since it&#39;s the last element to iterate on.</span>
    <span class="c1"># Otherwise, it&#39;ll return the element with the current index from the collection and reduce the index by 1</span>
    <span class="c1"># to get to the preceeding element.Python Generator functions allow you to declare a function that behaves likes an iterator, allowing programmers to make an iterator in a fast, easy, and clean way. An iterator is an object that can be iterated or looped upon. It is used to abstract a container of data to make it behave like an iterable object. </span>
    
    <span class="k">def</span> <span class="nf">__next__</span><span class="p">(</span><span class="bp">self</span><span class="p">):</span>
        <span class="k">if</span> <span class="bp">self</span><span class="o">.</span><span class="n">index</span> <span class="o">==</span> <span class="mi">0</span><span class="p">:</span>
            <span class="k">raise</span> <span class="ne">StopIteration</span>
        <span class="bp">self</span><span class="o">.</span><span class="n">index</span> <span class="o">=</span> <span class="bp">self</span><span class="o">.</span><span class="n">index</span> <span class="o">-</span> <span class="mi">1</span>
        <span class="k">return</span> <span class="bp">self</span><span class="o">.</span><span class="n">data</span><span class="p">[</span><span class="bp">self</span><span class="o">.</span><span class="n">index</span><span class="p">]</span>
</pre></div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<hr>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h2 id="Generators">Generators<a class="anchor-link" href="#Generators"></a></h2>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Python generators are somewhat similar to iterators. The resemblance can be confusing at times but the main difference is that iterators use <strong>return</strong> while generators use the keyword <strong>yield</strong> instead. We'll get to that in a minute.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Generators in python is dedicated to generate a sequence of values of any data type.The generators let us process only one value at a time and not store the entire values of the sequence into the memory. This can be very useful while processing or dealing with very large numbers or big files.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>The usage of <strong>yield</strong> in generators is what gives it the edge over iterators. The <strong>yield</strong> keyword allows the generator function to pause and store the state of current variables (this is why iterators are more memory-effecient) so that we can resume the generator function again anytime we need. Please refer to the examples below.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h3 id="Comparison-between-iterators-and-generators">Comparison between iterators and generators<a class="anchor-link" href="#Comparison-between-iterators-and-generators"></a></h3>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<ul>
<li><p>In iterators, we need to make use of the interator protocol methods (<strong>iter()</strong> and <strong>next()</strong>) but generators are simpler as we only need to use a function.</p>
</li>
<li><p>Generators use <strong>yield</strong>, iterators don't.</p>
</li>
<li><p>Implementing our own iterators requires us writing a class as shown earlier, generators don't need classes in python.</p>
</li>
<li><p>Generators are faster than iterators but iterators are more memory-effecient.</p>
</li>
</ul>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h2 id="Writing-your-first-generator-function">Writing your first generator function<a class="anchor-link" href="#Writing-your-first-generator-function"></a></h2>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Since our first iterator implementation was squaring a collection, our first generator function will do the same in order for you to understand how much easier generators are to write and implement.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="k">def</span> <span class="nf">gen</span><span class="p">(</span><span class="n">n</span><span class="p">):</span>
    <span class="k">for</span> <span class="n">i</span> <span class="ow">in</span> <span class="nb">range</span><span class="p">(</span><span class="n">n</span><span class="p">):</span>
        <span class="k">yield</span> <span class="n">i</span><span class="o">**</span><span class="mi">2</span>
</pre></div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>That's right.. That's it. The <strong>yield</strong> here is just a pause only since generators let us process one sequence value at a time. Now let's try and run this generator function.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="n">g</span> <span class="o">=</span> <span class="n">gen</span><span class="p">(</span><span class="mi">100000</span><span class="p">)</span>
<span class="n">g</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>&lt;generator object gen at 0x7f86cc3e49e0&gt;</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>As we can see, a generator object has been created and stored at g. Now we can iterate over this object and get the values of squares.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="k">for</span> <span class="n">i</span> <span class="ow">in</span> <span class="n">g</span><span class="p">:</span>
    <span class="nb">print</span><span class="p">(</span><span class="n">i</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Depending on your resources, sometimes large numbers as the one we passed on to the generator function in the above example would consume all of your memory. You can try that out using normal loops to iterate over a large number and then try again using generators to see the difference.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>We can also use the <strong>next()</strong> method to iterate over the generator object.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h2 id="Comparing-memory-efficiency-of-iterators-and-generators.">Comparing memory efficiency of iterators and generators.<a class="anchor-link" href="#Comparing-memory-efficiency-of-iterators-and-generators."></a></h2>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h4 id="Generator">Generator<a class="anchor-link" href="#Generator"></a></h4>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="k">def</span> <span class="nf">func</span><span class="p">():</span>
    <span class="n">i</span><span class="o">=</span><span class="mi">1</span>
    <span class="k">while</span> <span class="n">i</span><span class="o">&gt;</span><span class="mi">0</span><span class="p">:</span>
        <span class="k">yield</span> <span class="n">i</span>
        <span class="n">i</span><span class="o">-=</span><span class="mi">1</span>
<span class="nb">print</span><span class="p">(</span><span class="n">func</span><span class="p">()</span><span class="o">.</span><span class="n">__sizeof__</span><span class="p">())</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt"></div>
<div class="output_subarea output_stream output_stdout output_text">
<pre>96
</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h4 id="Iterator">Iterator<a class="anchor-link" href="#Iterator"></a></h4>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">iter</span><span class="p">([</span><span class="mi">1</span><span class="p">,</span><span class="mi">2</span><span class="p">])</span><span class="o">.</span><span class="n">__sizeof__</span><span class="p">()</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>32</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>As you can see above, the generator and iterator having the same functionality but still consuming different memory. Iterator is using lesser memory than generators.</p>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h2 id="Benefits-of-generators">Benefits of generators<a class="anchor-link" href="#Benefits-of-generators"></a></h2>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<ul>
<li>Working with data streams or large files - Usually for large csv files for example, we'd use a library like csv_reader. However, the amount of computation needed for extremely large files would probably exceed your memory resources. Suppose we want to have the rows of the file separately stored into an array or have the count of the rows instantly available, csv_reader will probably fail at counting large number of rows, but with generators using yield statement, it is rather a trivial task.</li>
</ul>
<ul>
<li>Generating Infinite Sequences - Since your computer memory is finite, an infinite sequence will definitly use all of it, which is why we would use generators for this task. Here is a little snippet to generate an infinite sequence.
<pre><code>def infinite_sequence():
  num = 0
  while True:
      yield num
      num += 1</code></pre>
</li>
</ul>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<h3 id="Example---Generating-Fibonacci-Numbers">Example - Generating Fibonacci Numbers<a class="anchor-link" href="#Example---Generating-Fibonacci-Numbers"></a></h3>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="k">def</span> <span class="nf">fibonacci</span><span class="p">(</span><span class="n">limit</span><span class="p">):</span>
    <span class="c1"># Initializing the first fibonacci numbers</span>
    <span class="n">a</span><span class="p">,</span> <span class="n">b</span> <span class="o">=</span> <span class="mi">0</span><span class="p">,</span> <span class="mi">1</span>
    
    <span class="c1"># We need the generator to yield fibonacci values one by one</span>
    <span class="c1"># until the limit is reached.</span>
    <span class="k">while</span> <span class="n">a</span> <span class="o">&lt;</span> <span class="n">limit</span><span class="p">:</span>
        <span class="k">yield</span> <span class="n">a</span>
        <span class="c1"># As you can notice here, the yield takes place</span>
        <span class="c1"># prior to calculating the upcoming number, so when the</span>
        <span class="c1"># generator is resumed, it will return back to this point</span>
        <span class="c1"># and resumes from there.</span>
        <span class="n">a</span><span class="p">,</span> <span class="n">b</span> <span class="o">=</span> <span class="n">b</span><span class="p">,</span> <span class="n">a</span><span class="o">+</span><span class="n">b</span>
</pre></div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing text_cell rendered">
<div class="prompt input_prompt">
</div>
<div class="inner_cell">
<div class="text_cell_render border-box-sizing rendered_html">
<p>Now lets try it out!</p>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="n">x</span> <span class="o">=</span> <span class="n">fibonacci</span><span class="p">(</span><span class="mi">30</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">x</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>0</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">x</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>1</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">x</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>1</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">x</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>2</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="nb">next</span><span class="p">(</span><span class="n">x</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt output_prompt">Out[&nbsp;]:</div>
<div class="output_text output_subarea output_execute_result">
<pre>3</pre>
</div>
</div>
</div>
</div>
</div>
<div class="cell border-box-sizing code_cell rendered">
<div class="input">
<div class="prompt input_prompt">In&nbsp;[&nbsp;]:</div>
<div class="inner_cell">
<div class="input_area">
<div class=" highlight hl-ipython3"><pre><span></span><span class="k">for</span> <span class="n">i</span> <span class="ow">in</span> <span class="n">x</span><span class="p">:</span>
    <span class="nb">print</span><span class="p">(</span><span class="n">i</span><span class="p">)</span>
</pre></div>
</div>
</div>
</div>
<div class="output_wrapper">
<div class="output">
<div class="output_area">
<div class="prompt"></div>
<div class="output_subarea output_stream output_stdout output_text">
<pre>5
8
13
21
</pre>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-md-12">
<h2> Related Notebooks </h2>
<ul class="list-group">
<li class="list-group-item"><a href="/notebook/249468051/How-To-Code-RNN-and-LSTM-Neural-Networks-in-Python/">How To Code RNN and LSTM Neural Networks in Python</a></li>
<li class="list-group-item"><a href="/notebook/17251835/Summarising-Aggregating-and-Grouping-data-in-Python-Pandas/">Summarising Aggregating and Grouping data in Python Pandas</a></li>
<li class="list-group-item"><a href="/notebook/716961781/Merge-and-Join-DataFrames-with-Pandas-in-Python/">Merge and Join DataFrames with Pandas in Python</a></li>
<li class="list-group-item"><a href="/notebook/626706996/Learn-And-Code-Confusion-Matrix-With-Python/">Learn And Code Confusion Matrix With Python</a></li>
<li class="list-group-item"><a href="/notebook/510557327/Strftime-and-Strptime-In-Python/">Strftime and Strptime In Python</a></li>
<li class="list-group-item"><a href="/notebook/775177178/String-And-Literal-In-Python-3/">String And Literal In Python 3</a></li>
<li class="list-group-item"><a href="/notebook/644259634/How-to-do-SQL-Select-and-Where-Using-Python-Pandas/">How to do SQL Select and Where Using Python Pandas</a></li>
<li class="list-group-item"><a href="/notebook/425091561/Covid-19-Curve-Fit-Using-Python-Pandas-And-Numpy/">Covid 19 Curve Fit Using Python Pandas And Numpy</a></li>
<li class="list-group-item"><a href="/notebook/923270235/Polynomial-Interpolation-Using-Python-Pandas-Numpy-And-Sklearn/">Polynomial Interpolation Using Python Pandas Numpy And Sklearn</a></li>
</ul>
</div>
</div>
</div>
<div class="col-md-3 d-none d-sm-none d-md-block">
<div class="sidebar-item">
<div class="make-me-sticky">
<ul id="side-menu">
<li>Menu loading...</li>

</ul>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-md-12">
<footer class="page-footer font-small pt-4 my-md-5 pt-md-5 border-top">
<div class="row col-md-12">
<div class="col-md-12">
<h5>Top Notebooks:</h5>
<ul class="list-inline font-small">
<li class="list-inline-item"><a href="/notebook/97969492/Data-Analysis-With-Pyspark-Dataframe/">Data Analysis With Pyspark Dataframe</a></li>
<li class="list-inline-item"><a href="/notebook/510557327/Strftime-and-Strptime-In-Python/">Strftime and Strptime In Python</a></li>
<li class="list-inline-item"><a href="/notebook/692176011/Numpy-Basics/">Numpy Basics</a></li>
<li class="list-inline-item"><a href="/notebook/669278718/Dictionaries-In-Python/">Dictionaries in Python</a></li>
<li class="list-inline-item"><a href="/notebook/297433759/How-To-Install-Python-With-Conda/#how-to-install-python3.9-with-conda">How To install Python3.9 With Conda</a></li>
<li class="list-inline-item"><a href="/notebook/775177178/String-And-Literal-In-Python-3/">String And Literal In Python 3</a></li>
</ul>
</div>
</div>
</footer>
</div>
</div>
</div>
</div>
</div>
<script src="/static/js/jquery.min.js"></script>
<script async src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.7/umd/popper.min.js"></script>
<script async src="https://maxcdn.bootstrapcdn.com/bootstrap/4.3.1/js/bootstrap.min.js"></script>
<script async type="text/javascript" src="/static/js/users.js"></script>
<script async type="text/javascript" src="/static/js/jquery.responsiveinstagram.min.js"></script>
<script type="text/javascript" src="//cdn.jsdelivr.net/blazy/latest/blazy.min.js"></script>
<script defer src="https://www.googletagmanager.com/gtag/js?id=UA-96605879-4"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-96605879-4');
</script>
<script type='text/javascript'>
    $(document).ready(function(){
        $('span[id="outgoinglink"]').bind('click touch',function(){
            var outlink=$(this).attr('data-attrib');
            if (outlink)
            {
                //console.log(outlink);
                window.location=outlink.slice(2);
            }

        });
    });
</script>
<script js>

$(document).on('ready', function () {
    var fixIg = function () {
        $('iframe').responsiveInstagram();
    };
    fixIg();
    });

  function resizeIframe(obj) {
    obj.style.height = obj.contentWindow.document.body.scrollHeight + 'px';
  }


(function(){
  var id = 'toc';
  var count = 0;
  $("#side-menu").text('');

  $("#container1 h1,#container1 h2").each(function() {

    var $section = $(this);
    var lis = $section.nextUntil("h2", 'h3');
    var tagname = $section[0].tagName;

    /*---------------------
     * Create menu item
     *--------------------*/
    var li = $('<li/>');
    if (tagname == 'H1') {
        var text = 'top';
        var a = $('<a/>', {
            text: 'Top',
            href: '#' + text
        });
    } else{
        var text = $(this).text().toLowerCase();
        //var text = text.substr(0, 1) + text.substr(1, text.length-2).replaceAll(" ", "-") + text.substr(text.length-1, 1);
        var text = text.replace(/^ /,'').replace(/\s$/,'').replaceAll(" ", "-");
        var a = $('<a/>', {
            text: $section.text(),
            href: '#' + text
        });
    /*all the code from here to...*/
    a.appendTo(li);

    /*---------------------
     * Add anchor
     *--------------------*/
    $section.attr('id', text);
    count++;


    $('#side-menu').append(li);
    /*...to here needs to be outside of else to make if part work */
    
    }
  });
})();
</script js>


<script src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.5/latest.js?config=TeX-AMS_HTML&delayStartupUntil=configured"></script>

<script defer type="text/x-mathjax-config">
    MathJax.Hub.Config({
        tex2jax: {
            inlineMath: [ ['$','$'], ["\\(","\\)"] ],
            displayMath: [ ['$$','$$'], ["\\[","\\]"] ],
            processEscapes: true,
            processEnvironments: true
        },
        // Center justify equations in code and markdown cells. Elsewhere
        // we use CSS to left justify single line equations in code cells.
        displayAlign: 'center',
        "HTML-CSS": {
            styles: {'.MathJax_Display': {"margin": 0}},
            linebreaks: { automatic: true }
        }
    });
    </script>
<script type="text/javascript">
    window.addEventListener('load', function () {
        MathJax.Hub.Configured()
    })
</script>
</body>
</html>
